<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" xml:lang="en-US" prefix="og: http://ogp.me/ns#"><head profile="http://gmpg.org/xfn/11"><link rel="stylesheet" href="//fonts.googleapis.com/css?family=Oswald%3A400" /><link rel="stylesheet" href="https://www.gearthblog.com/wp-content/cache/min/1/4967dae2bdfb34d44b84de4e49b7c38f.css" data-minify="1"/><link rel="stylesheet" href="https://www.gearthblog.com/wp-content/cache/min/1/4cc68869cbfbe29b0b3928ecd605580a.css" data-minify="1"/><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /><title>Google Earth placemarks to Excel - Google Earth Blog</title><meta name="viewport" content="width=device-width, initial-scale=1.0"/><link rel="canonical" href="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Google Earth placemarks to Excel - Google Earth Blog" /><meta property="og:description" content="It is often useful to be able to get Google Earth placemarks into Excel (or other spreadsheet application or even a database). One way to do this is to save your placemarks as a .KML file (do not use .KMZ) then rename the file to .XML. Then it will open in Excel. However, it will &hellip;" /><meta property="og:url" content="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html" /><meta property="og:site_name" content="Google Earth Blog" /><meta property="article:tag" content="KML javascript utilities" /><meta property="article:section" content="Site News" /><meta property="article:published_time" content="2017-01-19T08:04:27+00:00" /><meta property="article:modified_time" content="2017-01-20T03:52:06+00:00" /><meta property="og:updated_time" content="2017-01-20T03:52:06+00:00" /><meta property="og:image" content="https://www.gearthblog.com/wp-content/uploads/2017/01/EarthToExcel.png" /><meta property="og:image:width" content="676" /><meta property="og:image:height" content="252" /><link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Google Earth Blog &raquo; Feed" href="https://www.gearthblog.com/feed" /><link rel="alternate" type="application/rss+xml" title="Google Earth Blog &raquo; Comments Feed" href="https://www.gearthblog.com/comments/feed" /><link rel="alternate" type="application/rss+xml" title="Google Earth Blog &raquo; Google Earth placemarks to Excel Comments Feed" href="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html/feed" /><style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><!--[if lte IE 8]><link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://www.gearthblog.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' /> <![endif]--> <script>if (document.location.protocol != "https:") {
          document.location = document.URL.replace(/^http:/i, "https:");
      }</script> <script type='text/javascript' src='https://www.gearthblog.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script><script>jQueryWP = jQuery;</script> <script type='text/javascript' src='https://www.gearthblog.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <!--[if lt IE 9]> <script type='text/javascript' src='https://www.gearthblog.com/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3'></script> <![endif]--> <script type='text/javascript' src='https://www.gearthblog.com/wp-content/themes/metro/js/backstretch.js?ver=1.0.0'></script> <script type='text/javascript'>/*  */
var BackStretchImg = {"src":"https:\/\/www.gearthblog.com\/wp-content\/uploads\/2017\/02\/google-earth.jpg"};
/*  */</script> <script type='text/javascript' src='https://www.gearthblog.com/wp-content/themes/metro/js/backstretch-set.js?ver=1.0.0'></script> <script type='text/javascript' src='https://www.gearthblog.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21'></script> <script type='text/javascript' src='https://www.gearthblog.com/wp-content/plugins/jetpack/_inc/spin.js?ver=1.3'></script> <script type='text/javascript' src='https://www.gearthblog.com/wp-content/plugins/jetpack/_inc/jquery.spin.js?ver=1.3'></script> <link rel='https://api.w.org/' href='https://www.gearthblog.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.gearthblog.com/xmlrpc.php?rsd" /><meta name="generator" content="WordPress 4.7.2" /><link rel='shortlink' href='https://wp.me/p3pq06-5f8' /><link rel="alternate" type="application/json+oembed" href="https://www.gearthblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.gearthblog.com%2Fblog%2Farchives%2F2017%2F01%2Fgoogle-earth-placemarks-excel.html" /><link rel="alternate" type="text/xml+oembed" href="https://www.gearthblog.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.gearthblog.com%2Fblog%2Farchives%2F2017%2F01%2Fgoogle-earth-placemarks-excel.html&#038;format=xml" /> <script type="text/javascript">var _statcounter = _statcounter || [];
            _statcounter.push({"tags": {"author": "timothy"}});</script> <link rel='dns-prefetch' href='//v0.wordpress.com'><link rel='dns-prefetch' href='//jetpack.wordpress.com'><link rel='dns-prefetch' href='//s0.wp.com'><link rel='dns-prefetch' href='//s1.wp.com'><link rel='dns-prefetch' href='//s2.wp.com'><link rel='dns-prefetch' href='//public-api.wordpress.com'><link rel='dns-prefetch' href='//0.gravatar.com'><link rel='dns-prefetch' href='//1.gravatar.com'><link rel='dns-prefetch' href='//2.gravatar.com'><style type='text/css'>img#wpstats{display:none}</style><link rel="icon" href="https://www.gearthblog.com/wp-content/themes/metro/images/favicon.ico" /><link rel="pingback" href="https://www.gearthblog.com/xmlrpc.php" /> <script type="text/javascript">var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));</script> <script type="text/javascript">try {
var pageTracker = _gat._getTracker("UA-167207-1");
pageTracker._trackPageview();
} catch(err) {}</script><style type="text/css">#header{background:url(https://www.gearthblog.com/wp-content/uploads/2017/02/logo.png) no-repeat !important}</style> <script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script><style type="text/css" media="screen">.simple-social-icons ul li a, .simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus{background-color:#999 !important;border-radius:3px;color:#fff !important;border:0px
#fff solid !important;font-size:18px;padding:9px}.simple-social-icons ul li a:hover, .simple-social-icons ul li a:focus{background-color:#666 !important;border-color:#fff !important;color:#fff !important}.simple-social-icons ul li a:focus{outline:1px
dotted #666 !important}</style></head><body data-rsssl=1 class="post-template-default single single-post postid-20158 single-format-standard custom-background custom-header header-image content-sidebar"><br /><div align="center" class="topmainad"><script type="text/javascript">google_ad_client = "ca-pub-5879611162016216";
/* 728x90, created 6/4/08 */
google_ad_slot = "9677538537";
google_ad_width = 728;
google_ad_height = 90;</script> <script type="text/javascript"
src="https://pagead2.googlesyndication.com/pagead/show_ads.js"></script></div><div id="wrap"><div id="header"><div class="wrap"><div id="title-area"><p id="title"><a href="https://www.gearthblog.com/">Google Earth Blog</a></p></div><div class="widget-area header-widget-area"><div id="simple-social-icons-2" class="widget simple-social-icons"><div class="widget-wrap"><ul class="alignleft"><li class="ssi-email"><a href="https://www.gearthblog.com/contact.html" ><svg role="img" class="social-email" aria-labelledby="social-email"><title id="social-email">Email</title><use xlink:href="https://www.gearthblog.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-email"></use></svg></a></li><li class="ssi-facebook"><a href="https://www.facebook.com/gearthblog" ><svg role="img" class="social-facebook" aria-labelledby="social-facebook"><title id="social-facebook">Facebook</title><use xlink:href="https://www.gearthblog.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-facebook"></use></svg></a></li><li class="ssi-gplus"><a href="https://plus.google.com/100194466628055570269" ><svg role="img" class="social-gplus" aria-labelledby="social-gplus"><title id="social-gplus">Google+</title><use xlink:href="https://www.gearthblog.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-gplus"></use></svg></a></li><li class="ssi-rss"><a href="https://www.gearthblog.com/feed/" ><svg role="img" class="social-rss" aria-labelledby="social-rss"><title id="social-rss">RSS</title><use xlink:href="https://www.gearthblog.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-rss"></use></svg></a></li><li class="ssi-twitter"><a href="http://twitter.com/gearthblog/" ><svg role="img" class="social-twitter" aria-labelledby="social-twitter"><title id="social-twitter">Twitter</title><use xlink:href="https://www.gearthblog.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-twitter"></use></svg></a></li></ul></div></div></div></div></div><div id="nav"><div class="wrap"><ul id="menu-main-menu" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-8" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-8"><a href="https://www.gearthblog.com/">Home</a></li><li id="menu-item-5577" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5577"><a href="https://www.gearthblog.com/about">About</a></li><li id="menu-item-5574" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5574"><a href="https://www.gearthblog.com/contact">Contact</a></li><li id="menu-item-5575" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5575"><a href="https://www.gearthblog.com/basics">Basics</a></li><li id="menu-item-5578" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5578"><a href="https://www.gearthblog.com/reference">Links</a></li><li id="menu-item-3064" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3064"><a href="https://www.gearthblog.com/category/google_earth_tips">Tips</a></li><li id="menu-item-3063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3063"><a href="https://www.gearthblog.com/category/3d_models">3D Models</a></li><li id="menu-item-3065" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3065"><a href="https://www.gearthblog.com/category/sightseeing">Sightseeing</a></li><li id="menu-item-3066" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3066"><a href="https://www.gearthblog.com/category/video">Videos</a></li></ul></div></div><div id="inner"><div id="content-sidebar-wrap"><div id="content" class="hfeed"><div align="center"><script type="text/javascript">google_ad_client = "ca-pub-5879611162016216";
/* 468x15, created 6/2/08 */
google_ad_slot = "0895746135";
google_ad_width = 468;
google_ad_height = 15;</script> <script type="text/javascript"
src="https://pagead2.googlesyndication.com/pagead/show_ads.js"></script></div><br /><div class="post-20158 post type-post status-publish format-standard has-post-thumbnail hentry category-site-news tag-kml-javascript-utilities entry"><h1 class="entry-title">Google Earth placemarks to Excel</h1><div class="post-info"><span class="date published time" title="2017-01-19T08:04:27+00:00">January 19, 2017</span></div><div class="entry-content"><p><img src="https://www.gearthblog.com/wp-content/uploads/2017/01/EarthToExcel.png" alt="" /></p><p>It is often useful to be able to get Google Earth placemarks into Excel (or other spreadsheet application or even a database). One way to do this is to save your placemarks as a .KML file (do not use .KMZ) then rename the file to .XML. Then it will open in Excel. However, it will typically need quite a lot of cleaning up after that. So, we thought it might be useful to have a simple converter that takes a .KML or .KMZ and extracts all the placemarks (points only, ignoring polygons, paths and other features) and converts it to csv for easy import into Excel or other application. So, here it is:</p><style>input[type="file"]{padding:4px;color:black}</style><p><script src="https://www.gearthblog.com/js/utils/jszip.3.1.3.min.js"></script><script src="https://www.gearthblog.com/js/utils/FileSaver.min.js" ></script><script  src="https://www.gearthblog.com/js/babel/polyfill.min.js"></script><script  src="https://www.gearthblog.com/js/babel/kml_babel_2017-01-19.js"></script> <script  src="https://www.gearthblog.com/js/PlacemarkToExcel.js"></script></p><p><input type="file" id="file" name="files[]" multiple /></p><p><button onclick="convert()">Convert</button></p><div id="output" ></div><p>&nbsp;</p><p>It only extracts the placemark name, description, latitude and longitude.</p><p>If you need other fields, or features, or encounter any bugs, please let us know in the comments.</p><p>To convert the other way (Excel to Google Earth), the easiest method is to use Google Earth Pro&#8217;s import feature <a href="https://www.gearthblog.com/blog/archives/2015/02/google-earth-pro-importing-addresses.html">described here</a>. Another more complicated technique can <a href="https://www.gearthblog.com/blog/archives/2015/08/excel-kml-via-xml-export.html">be found here</a>.</p><div class="wp-biographia-container-top" style="background-color: #FFEAA8; border-top: 4px solid #000000;"><div class="wp-biographia-pic" style="height:60px; width:60px;"><img alt='' src='https://secure.gravatar.com/avatar/92e68eff17388e59c80388fbe5d70b7d?s=60&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/92e68eff17388e59c80388fbe5d70b7d?s=120&amp;d=mm&amp;r=g 2x' class='wp-biographia-avatar avatar-60 photo' height='60' width='60' /></div><div class="wp-biographia-text"><h3>About Timothy Whitehead</h3><p>Timothy has been using Google Earth since 2004 when it was still called Keyhole  before it was renamed Google Earth in 2005 and has been a huge fan ever since. He is a programmer working for <a href="http://www.redwingaerobatx.com">Red Wing Aerobatx</a> and lives in Cape Town, South Africa.</p><div class="wp-biographia-links"><small><ul class="wp-biographia-list wp-biographia-list-text"><li><a href="https://plus.google.com/u/0/+TimothyWhiteheadzm/posts?rel=author" target="_self" title="Timothy Whitehead On Google+" class="wp-biographia-link-text">Google+</a></li> |<li><a href="https://www.gearthblog.com/blog/archives/author/timothy" target="_self" title="More Posts By Timothy Whitehead" class="wp-biographia-link-text">More Posts (649)</a></li></ul></small></div></div></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-20158" class="share-twitter sd-button share-icon" href="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-20158" class="share-facebook sd-button share-icon" href="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-20158" class="share-google-plus-1 sd-button share-icon" href="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-end"></li></ul></div></div></div></div><div class="post-meta"><span class="categories">Filed Under: <a href="https://www.gearthblog.com/category/site-news" rel="category tag">Site News</a></span> <span class="tags">Tagged With: <a href="https://www.gearthblog.com/tag/kml-javascript-utilities" rel="tag">KML javascript utilities</a></span> <span class="post-comments"><a href="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html#comments">12 Comments</a></span><br clear="all" /></div></div><br clear="all" /><div style="float:left; padding-left:5px;"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:336px;height:280px"
data-ad-client="ca-pub-5879611162016216"
data-ad-slot="7627137898"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><div style="float:left; padding-left:5px;" class="secondad"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:336px;height:280px"
data-ad-client="ca-pub-5879611162016216"
data-ad-slot="7627137898"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div> <br clear="all" /><div id="comments"><h3><span class="comments-title">Comments</span></h3><ol class="comment-list"><li class="comment even thread-even depth-1" id="comment-375755"><div class="comment-header"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/e0202bba26c5b4b1865a1d9a5f7f4dec?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e0202bba26c5b4b1865a1d9a5f7f4dec?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><cite class="fn"><a href='https://plus.google.com/118133133456650420096' rel='external nofollow' class='url'>Stewart Young</a></cite> <span class="says">says:</span></div><div class="comment-meta commentmetadata"> <a href="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html#comment-375755">January 19, 2017 at 11:39 am</a></div></div><div class="comment-content"><p>How long does the process take?</p></div><div class="reply"> <a rel='nofollow' class='comment-reply-link' href='https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html?replytocom=375755#respond' onclick='return addComment.moveForm( "comment-375755", "375755", "respond", "20158" )' aria-label='Reply to Stewart Young'>Reply</a></div><ul class="children"><li class="comment byuser comment-author-timothy bypostauthor odd alt depth-2" id="comment-375843"><div class="comment-header"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/92e68eff17388e59c80388fbe5d70b7d?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/92e68eff17388e59c80388fbe5d70b7d?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><cite class="fn">Timothy Whitehead</cite> <span class="says">says:</span></div><div class="comment-meta commentmetadata"> <a href="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html#comment-375843">January 20, 2017 at 3:57 am</a></div></div><div class="comment-content"><p>It should take a few seconds. It should also say &#8216;Done&#8217; once it is finished. If it does say &#8216;done&#8217;, then you may be missing the download (it depends on your browser how that is displayed). If it doesn&#8217;t get to &#8216;done&#8217; then please let me know what browser you are using, and if the KML is not sensitive then send me a copy of the KML so I can check for bugs.</p></div><div class="reply"> <a rel='nofollow' class='comment-reply-link' href='https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html?replytocom=375843#respond' onclick='return addComment.moveForm( "comment-375843", "375843", "respond", "20158" )' aria-label='Reply to Timothy Whitehead'>Reply</a></div></li></ul></li><li class="comment even thread-odd thread-alt depth-1" id="comment-375928"><div class="comment-header"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/1a784ec8ac9caf045a699c3efd24a6d9?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1a784ec8ac9caf045a699c3efd24a6d9?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><cite class="fn"><a href='http://offroading-home.com' rel='external nofollow' class='url'>DJ</a></cite> <span class="says">says:</span></div><div class="comment-meta commentmetadata"> <a href="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html#comment-375928">January 21, 2017 at 2:01 pm</a></div></div><div class="comment-content"><p>Timothy&#8230; as you may remember, I&#8217;ve spent several years serving &#8220;offroading maps&#8221; and nearly all of them have been &#8220;handcrafted&#8221; using Google&#8217;s KML styles and functions because there has been almost no &#8220;transposing&#8221; software available. Excel, jEdit, XML notepad, GPS Visualizer and (when made free) GooglePro have been my best friends. And I&#8217;ve even dabbled with MS Access to store the various placemark data- although with little success. I&#8217;ve tried to write an XML &#8220;extractor&#8221; but of course I would want to bring ALL available data if it was presented including those in the  and other methods &#8211; iterating through them and creating columns</p><p>I&#8217;m glad to see you working on this &#8211; a lot of my files fly through your converter with flying colors. Some do not, and &#8220;hang&#8221; &#8211; although I never let them go longer than 60 seconds. It seems like the shorter ones make it and the &#8220;longer&#8221; ones do not but I can&#8217;t be sure. Responding to your plea for troubleshooting info I offer the two files below.</p><p>I haven&#8217;t actually checked the &#8220;converted&#8221; files created thoroughly although it looks like when you bring over the  the parser strips out the &#8221; &lt;![CDATA[ &quot; code and adds a bunch of double quotes. I&#039;ve got to look at that further to see what that means to being able to get them back into KML once they&#039;ve been manipulated.</p><p>Also, it would be more convenient if somehow a bit of the file structure could be captured (i.e. ) but I haven&#8217;t thought about how that could be reflected in CSV so that it would appear in Excel (unless a  set up a value in a new column with its  as the value which repeated for all lines until a new column was set and changed the name for the value.</p><p><a href="https://dl.dropboxusercontent.com/u/567495/Temp/Jawbone-Butterbredt%20ACEC.kml" rel="nofollow">https://dl.dropboxusercontent.com/u/567495/Temp/Jawbone-Butterbredt%20ACEC.kml</a> &#8211; hangs with &#8220;parsing&#8221;</p><p><a href="https://dl.dropboxusercontent.com/u/567495/Temp/Utah%20USGS%20Features.kmz" rel="nofollow">https://dl.dropboxusercontent.com/u/567495/Temp/Utah%20USGS%20Features.kmz</a> &#8211; hangs with &#8220;processing&#8221;</p></div><div class="reply"> <a rel='nofollow' class='comment-reply-link' href='https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html?replytocom=375928#respond' onclick='return addComment.moveForm( "comment-375928", "375928", "respond", "20158" )' aria-label='Reply to DJ'>Reply</a></div><ul class="children"><li class="comment odd alt depth-2" id="comment-375930"><div class="comment-header"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/1a784ec8ac9caf045a699c3efd24a6d9?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1a784ec8ac9caf045a699c3efd24a6d9?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><cite class="fn"><a href='http://offroadinghome.com' rel='external nofollow' class='url'>DJ</a></cite> <span class="says">says:</span></div><div class="comment-meta commentmetadata"> <a href="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html#comment-375930">January 21, 2017 at 2:03 pm</a></div></div><div class="comment-content"><p>sorry timothy &#8211; my website doesn&#8217;t have a hyphen <a href="http://offroadinghome.com/" rel="nofollow">http://offroadinghome.com/</a></p></div><div class="reply"> <a rel='nofollow' class='comment-reply-link' href='https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html?replytocom=375930#respond' onclick='return addComment.moveForm( "comment-375930", "375930", "respond", "20158" )' aria-label='Reply to DJ'>Reply</a></div></li><li class="comment even depth-2" id="comment-375965"><div class="comment-header"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/1a784ec8ac9caf045a699c3efd24a6d9?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1a784ec8ac9caf045a699c3efd24a6d9?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><cite class="fn"><a href='http://offroadinghome.com' rel='external nofollow' class='url'>dj</a></cite> <span class="says">says:</span></div><div class="comment-meta commentmetadata"> <a href="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html#comment-375965">January 22, 2017 at 2:50 pm</a></div></div><div class="comment-content"><p>I notice that the parser has stripped out my references to KML tags so doesn&#8217;t make sense in parts. ( i.e.  with its  /  pairs and    &#8212;  (let&#8217;s see if adding spaces helps)</p></div><div class="reply"> <a rel='nofollow' class='comment-reply-link' href='https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html?replytocom=375965#respond' onclick='return addComment.moveForm( "comment-375965", "375965", "respond", "20158" )' aria-label='Reply to dj'>Reply</a></div><ul class="children"><li class="comment odd alt depth-3" id="comment-375966"><div class="comment-header"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/1a784ec8ac9caf045a699c3efd24a6d9?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1a784ec8ac9caf045a699c3efd24a6d9?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><cite class="fn"><a href='http://offroadinghome.com' rel='external nofollow' class='url'>dj</a></cite> <span class="says">says:</span></div><div class="comment-meta commentmetadata"> <a href="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html#comment-375966">January 22, 2017 at 2:54 pm</a></div></div><div class="comment-content"><p>Nope &#8211; it didn&#8217;t, let&#8217;s try with backslashes: i.e. \ with its  \ / \ pairs.</p></div><div class="reply"> <a rel='nofollow' class='comment-reply-link' href='https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html?replytocom=375966#respond' onclick='return addComment.moveForm( "comment-375966", "375966", "respond", "20158" )' aria-label='Reply to dj'>Reply</a></div></li><li class="comment even depth-3" id="comment-375967"><div class="comment-header"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/1a784ec8ac9caf045a699c3efd24a6d9?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1a784ec8ac9caf045a699c3efd24a6d9?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><cite class="fn"><a href='http://offroadinghome.com' rel='external nofollow' class='url'>dj</a></cite> <span class="says">says:</span></div><div class="comment-meta commentmetadata"> <a href="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html#comment-375967">January 22, 2017 at 3:02 pm</a></div></div><div class="comment-content"><p>NOPE trying with (amp)lt; and (amp)gt; only gave me an invalid security token.</p><p>I&#8217;ll try substituting the angled brackets with parens:</p><p>&#8220;i.e.  (ExtendedData) with its (name) / (value) pairs&#8221;</p></div><div class="reply"> <a rel='nofollow' class='comment-reply-link' href='https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html?replytocom=375967#respond' onclick='return addComment.moveForm( "comment-375967", "375967", "respond", "20158" )' aria-label='Reply to dj'>Reply</a></div></li></ul></li><li class="comment odd alt depth-2" id="comment-375970"><div class="comment-header"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/1a784ec8ac9caf045a699c3efd24a6d9?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1a784ec8ac9caf045a699c3efd24a6d9?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><cite class="fn"><a href='http://offroadinghome.com' rel='external nofollow' class='url'>dj</a></cite> <span class="says">says:</span></div><div class="comment-meta commentmetadata"> <a href="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html#comment-375970">January 22, 2017 at 3:10 pm</a></div></div><div class="comment-content"><p>Timothy &#8211; another area the parser made difficult was my statement that &#8220;when the converter brings over the (description) it parses out the &#8221;  &#8221; tag needed to be able to insert table&#8217;s and other HTML stuff.</p></div><div class="reply"> <a rel='nofollow' class='comment-reply-link' href='https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html?replytocom=375970#respond' onclick='return addComment.moveForm( "comment-375970", "375970", "respond", "20158" )' aria-label='Reply to dj'>Reply</a></div><ul class="children"><li class="comment even depth-3" id="comment-375971"><div class="comment-header"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/1a784ec8ac9caf045a699c3efd24a6d9?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/1a784ec8ac9caf045a699c3efd24a6d9?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><cite class="fn"><a href='http://offroadinghome.com' rel='external nofollow' class='url'>dj</a></cite> <span class="says">says:</span></div><div class="comment-meta commentmetadata"> <a href="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html#comment-375971">January 22, 2017 at 3:14 pm</a></div></div><div class="comment-content"><p>sorry, this is just bizzare &#8211; the parser left the ” &lt;![CDATA[ &quot;  in above but took it out in my comment I just made.   &lt; ! [ C D A T A [  &#8211; is needed to get Earth to parse HTML code in the description tags correctly and the converter seems to remove it from them.</p></div><div class="reply"> <a rel='nofollow' class='comment-reply-link' href='https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html?replytocom=375971#respond' onclick='return addComment.moveForm( "comment-375971", "375971", "respond", "20158" )' aria-label='Reply to dj'>Reply</a></div></li></ul></li><li class="comment byuser comment-author-timothy bypostauthor odd alt depth-2" id="comment-376026"><div class="comment-header"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/92e68eff17388e59c80388fbe5d70b7d?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/92e68eff17388e59c80388fbe5d70b7d?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><cite class="fn">Timothy Whitehead</cite> <span class="says">says:</span></div><div class="comment-meta commentmetadata"> <a href="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html#comment-376026">January 23, 2017 at 1:35 pm</a></div></div><div class="comment-content"><p>Hi DJ, I will go through your sample files and see if I can get them to work. My first question is whether or not they are generated by Google Earth, or you generate them yourself. I would like to know whether the <antialias> tag found in the first sample is undocumented KML or an error.</antialias></p></div><div class="reply"> <a rel='nofollow' class='comment-reply-link' href='https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html?replytocom=376026#respond' onclick='return addComment.moveForm( "comment-376026", "376026", "respond", "20158" )' aria-label='Reply to Timothy Whitehead'>Reply</a></div></li></ul></li><li class="comment even thread-even depth-1" id="comment-376025"><div class="comment-header"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/8afc950695b8e1d6ee013562d29f71fb?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/8afc950695b8e1d6ee013562d29f71fb?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><cite class="fn"><a href='https://plus.google.com/+AdamSimmons' rel='external nofollow' class='url'>Adam Simmons</a></cite> <span class="says">says:</span></div><div class="comment-meta commentmetadata"> <a href="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html#comment-376025">January 23, 2017 at 1:22 pm</a></div></div><div class="comment-content"><p>As a huge user of KML over the years my experience and users I represent has been converting KML back into a readable format such as CSV. As you stated it can indeed be messy. Uploading a KML to Google Drive&#8217;s Fusion Tables has been a good way to do something basic but it becomes an art to find a converter that also can handle the flexibility of HTML code one might encounter in the description field and break those apart into separate columns in a CSV. The tool that does this in a generic way and offers the most adaptability to the possible KML varities for what people put in the description could fulfill a good market gap as Google Sunsets Google Earth over the next couple years as the community attempts to restandardize KML into something else. Caveat: I&#8217;m still hoping on a gambler&#8217;s odds that Google rethinks their stance on Geo products and reinvests but SIGH.</p></div><div class="reply"> <a rel='nofollow' class='comment-reply-link' href='https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html?replytocom=376025#respond' onclick='return addComment.moveForm( "comment-376025", "376025", "respond", "20158" )' aria-label='Reply to Adam Simmons'>Reply</a></div></li><li class="comment odd alt thread-odd thread-alt depth-1" id="comment-377201"><div class="comment-header"><div class="comment-author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/4559d37fb89434eff9662eda3cb2a88a?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/4559d37fb89434eff9662eda3cb2a88a?s=96&amp;d=mm&amp;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /><cite class="fn">Anusha Sharma Pandey</cite> <span class="says">says:</span></div><div class="comment-meta commentmetadata"> <a href="https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html#comment-377201">February 23, 2017 at 6:47 pm</a></div></div><div class="comment-content"><p>It works. I am very excited. thank you so much</p></div><div class="reply"> <a rel='nofollow' class='comment-reply-link' href='https://www.gearthblog.com/blog/archives/2017/01/google-earth-placemarks-excel.html?replytocom=377201#respond' onclick='return addComment.moveForm( "comment-377201", "377201", "respond", "20158" )' aria-label='Reply to Anusha Sharma Pandey'>Reply</a></div></li></ol></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/archives/2017/01/google-earth-placemarks-excel.html#respond" style="display:none;">Cancel reply</a></small></h3><form id="commentform" class="comment-form"> <iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=50387158&#038;postid=20158&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=4.6&#038;sig=2badac1e61818a2d0da71324eadab9d7cad85a94#parent=https%3A%2F%2Fwww.gearthblog.com%2Fblog%2Farchives%2F2017%2F01%2Fgoogle-earth-placemarks-excel.html" allowtransparency="false" style="width:100%; height: 430px;border:0;" frameBorder="0" scrolling="no" name="jetpack_remote_comment" id="jetpack_remote_comment"></iframe></form></div> <input type="hidden" name="comment_parent" id="comment_parent" value="" /><div class="loop-nav"><br /><div class="previous">Previous post: <a href="https://www.gearthblog.com/blog/archives/2017/01/draco-3d-compression-library.html" rel="prev">Draco 3D compression library</a></div><br /><div class="next">Next post: <a href="https://www.gearthblog.com/blog/archives/2017/01/new-google-earth-version-7-1-8-3036.html" rel="next">New Google Earth Version 7.1.8.3036</a></div></div></div><div id="sidebar" class="sidebar widget-area"><div id="text-3" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><form action="https://www.google.com" id="cse-search-box" target="_blank"><div> <input type="hidden" name="cx" value="partner-pub-5879611162016216:8243249098" /> <input type="hidden" name="ie" value="UTF-8" /> <input type="text" name="q" size="25" /> <input type="submit" name="sa" value="Search" /></div></form> <script type="text/javascript" src="https://www.google.com/coop/cse/brand?form=cse-search-box&amp;lang=en"></script></div></div></div><div id="text-2" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><script type="text/javascript">google_ad_client = "ca-pub-5879611162016216";
/* New Sidebar */
google_ad_slot = "2057651097";
google_ad_width = 336;
google_ad_height = 280;</script> <script type="text/javascript"
src="https://pagead2.googlesyndication.com/pagead/show_ads.js"></script></div></div></div><div id="top-posts-2" class="widget widget_top-posts"><div class="widget-wrap"><h4 class="widget-title widgettitle"><span class="widget-headline">Hot Posts</span></h4><ul><li> <a href="https://www.gearthblog.com/blog/archives/2017/02/fun-google-earths-terrain-exaggeration.html" class="bump-view" data-bump-view="tp"> Fun with Google Earth&#039;s terrain exaggeration </a></li><li> <a href="https://www.gearthblog.com/blog/archives/2012/03/google_earth_live.html" class="bump-view" data-bump-view="tp"> Google Earth live? </a></li><li> <a href="https://www.gearthblog.com/blog/archives/2017/02/google-earth-imagery-update-earthquake-fire.html" class="bump-view" data-bump-view="tp"> Google Earth imagery update, earthquake and fire </a></li><li> <a href="https://www.gearthblog.com/blog/archives/2017/02/people-google-earths-3d-imagery.html" class="bump-view" data-bump-view="tp"> People in Google Earth&#039;s 3D imagery </a></li><li> <a href="https://www.gearthblog.com/satellites" class="bump-view" data-bump-view="tp"> Positions of Satellites Around Earth </a></li><li> <a href="https://www.gearthblog.com/blog/archives/2011/03/find_out_where_the_street_view_cars.html" class="bump-view" data-bump-view="tp"> Find out where the Street View cars are currently on the road </a></li><li> <a href="https://www.gearthblog.com/blog/archives/2010/10/how_often_does_google_update_the_im.html" class="bump-view" data-bump-view="tp"> How often does Google update the imagery in Google Earth? </a></li><li> <a href="https://www.gearthblog.com/blog/archives/2009/02/google_earth_5_historical_imagery.html" class="bump-view" data-bump-view="tp"> Google Earth 5 - Historical Imagery </a></li><li> <a href="https://www.gearthblog.com/blog/archives/2015/11/importing-geotagged-photos-into-google-earth.html" class="bump-view" data-bump-view="tp"> Importing geotagged photos into Google Earth </a></li><li> <a href="https://www.gearthblog.com/blog/archives/2014/12/google-earth-api-deprecated.html" class="bump-view" data-bump-view="tp"> Google Earth Api deprecated </a></li></ul></div></div><div id="categories-3" class="widget widget_categories"><div class="widget-wrap"><h4 class="widget-title widgettitle"><span class="widget-headline">Categories</span></h4><ul><li class="cat-item cat-item-11"><a href="https://www.gearthblog.com/category/3d_models" >3D Models</a> (792)</li><li class="cat-item cat-item-10"><a href="https://www.gearthblog.com/category/applications" >Applications</a> (708)</li><li class="cat-item cat-item-12"><a href="https://www.gearthblog.com/category/business" >Business</a> (288)</li><li class="cat-item cat-item-18"><a href="https://www.gearthblog.com/category/environment" >Environment</a> (353)</li><li class="cat-item cat-item-8"><a href="https://www.gearthblog.com/category/flying" >Flying</a> (208)</li><li class="cat-item cat-item-20"><a href="https://www.gearthblog.com/category/ge_plugin" >GE Plugin</a> (282)</li><li class="cat-item cat-item-13"><a href="https://www.gearthblog.com/category/google_earth_news" >Google Earth News</a> (1,757)</li><li class="cat-item cat-item-6"><a href="https://www.gearthblog.com/category/google_earth_tips" >Google Earth Tips</a> (590)</li><li class="cat-item cat-item-9"><a href="https://www.gearthblog.com/category/gps" >GPS</a> (136)</li><li class="cat-item cat-item-7"><a href="https://www.gearthblog.com/category/navigation" >Navigation</a> (227)</li><li class="cat-item cat-item-5"><a href="https://www.gearthblog.com/category/network_links" >Network Links</a> (214)</li><li class="cat-item cat-item-15"><a href="https://www.gearthblog.com/category/sailing" >Sailing</a> (121)</li><li class="cat-item cat-item-16"><a href="https://www.gearthblog.com/category/science" >Science</a> (499)</li><li class="cat-item cat-item-4"><a href="https://www.gearthblog.com/category/sightseeing" >Sightseeing</a> (1,902)</li><li class="cat-item cat-item-1"><a href="https://www.gearthblog.com/category/site-news" >Site News</a> (480)</li><li class="cat-item cat-item-19"><a href="https://www.gearthblog.com/category/sky" >Sky</a> (67)</li><li class="cat-item cat-item-17"><a href="https://www.gearthblog.com/category/sports" >Sports</a> (154)</li><li class="cat-item cat-item-819"><a href="https://www.gearthblog.com/category/street-view-2" >Street View</a> (47)</li><li class="cat-item cat-item-21"><a href="https://www.gearthblog.com/category/tours" >Tours</a> (117)</li><li class="cat-item cat-item-14"><a href="https://www.gearthblog.com/category/video" >Video</a> (421)</li><li class="cat-item cat-item-3"><a href="https://www.gearthblog.com/category/weather" >Weather</a> (180)</li></ul></div></div><div id="text-4" class="widget widget_text"><div class="widget-wrap"><div class="textwidget"><a href="https://www.gearthblog.com/satellites.html">Google Earth Satellites</a></div></div></div></div></div></div> <script type="text/javascript">var _paq = _paq || [];
  _paq.push(["trackPageView"]);
  _paq.push(["enableLinkTracking"]);

  (function() {
    var u=(("https:" == document.location.protocol) ? "https" : "http") + "://www.greenmellenmedia.com/piwik/";
    _paq.push(["setTrackerUrl", u+"piwik.php"]);
    _paq.push(["setSiteId", "2"]);
    var d=document, g=d.createElement("script"), s=d.getElementsByTagName("script")[0]; g.type="text/javascript";
    g.defer=true; g.async=true; g.src=u+"piwik.js"; s.parentNode.insertBefore(g,s);
  })();</script> </div><div id="footer" class="footer"><div class="wrap"><div class="gototop"><p>Copyright 2005-&#x000A9;&nbsp;2017 Frank Taylor. All Rights Reserved.</p></div><div class="creds"><p>This blog and its author are not an official source of information from Google that produces and owns Google Earth
Google and Google Earth are trademarks of Google Inc..
All image screenshots from Google Earth are Copyright Google.
All other trademarks appearing here are the trademarks of their respective owners.</p></div></div></div>  <script>/*<![CDATA[*/var sc_project=920145; 
        var sc_security="09c9af5e"; 
      var sc_invisible=1;
        var scJsHost = (("https:" == document.location.protocol) ?
        "https://secure." : "http://www.");
    //-->
document.write("<sc"+"ript src='" +scJsHost +"statcounter.com/counter/counter.js'></"+"script>");/*]]>*/</script> <noscript><div class="statcounter"><a title="web analytics" href="https://statcounter.com/"><img class="statcounter" src="https://c.statcounter.com/920145/0/09c9af5e/1/" alt="web analytics" /></a></div></noscript>  <script type="text/javascript">window.WPCOM_sharing_counts = {"https:\/\/www.gearthblog.com\/blog\/archives\/2017\/01\/google-earth-placemarks-excel.html":20158};</script> <script>if (document.location.protocol != "https:") {
          document.location = document.URL.replace(/^http:/i, "https:");
      }</script> <script type='text/javascript' src='https://www.gearthblog.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3'></script> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201708'></script> <script type='text/javascript' src='https://www.gearthblog.com/wp-includes/js/comment-reply.min.js?ver=4.7.2'></script> <script type='text/javascript' src='https://www.gearthblog.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script> <script type='text/javascript' src='https://www.gearthblog.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.5'></script> <script type='text/javascript' src='https://www.gearthblog.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=2.4.2'></script> <script type='text/javascript' src='https://www.gearthblog.com/wp-content/themes/genesis/lib/js/menu/superfish.compat.min.js?ver=2.4.2'></script> <script type='text/javascript'>/*<![CDATA[*//*  */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.gearthblog.com\/wp-admin\/admin-ajax.php","nonce":"585edb0e5b","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.gearthblog.com\/wp-login.php?redirect_to=https%3A%2F%2Fwww.gearthblog.com%2Fblog%2Farchives%2F2017%2F01%2Fgoogle-earth-placemarks-excel.html","blog_id":"1","local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/*  *//*]]>*/</script> <script type='text/javascript' src='https://www.gearthblog.com/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel.js?ver=20160325'></script> <script type='text/javascript' src='https://www.gearthblog.com/wp-includes/js/wp-embed.min.js?ver=4.7.2'></script> <script type='text/javascript'>/*  */
var sharing_js_options = {"lang":"en","counts":"1"};
/*  */</script> <script type='text/javascript' src='https://www.gearthblog.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.6'></script> <script type='text/javascript'>var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});</script> <!--[if IE]> <script type="text/javascript">if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}</script> <![endif]--> <script type="text/javascript">/*<![CDATA[*/var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=50387158&postid=20158&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.6&sig=2badac1e61818a2d0da71324eadab9d7cad85a94#parent=https%3A%2F%2Fwww.gearthblog.com%2Fblog%2Farchives%2F2017%2F01%2Fgoogle-earth-placemarks-excel.html" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=50387158&postid=20158&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.6&sig=2badac1e61818a2d0da71324eadab9d7cad85a94#parent=https%3A%2F%2Fwww.gearthblog.com%2Fblog%2Farchives%2F2017%2F01%2Fgoogle-earth-placemarks-excel.html";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}/*]]>*/</script> <script type='text/javascript' src='https://stats.wp.com/e-201708.js' async defer></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.6',blog:'50387158',post:'20158',tz:'-4',srv:'www.gearthblog.com'} ]);
	_stq.push([ 'clickTrackerInit', '50387158', '20158' ]);</script> </body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->